Newsroom Blog

Georgia Nursing Leadership Coalition to Hold Leadership Institute at Clayton State

Georgia Nursing Leadership Coalition to Hold Leadership Institute at Clayton State

Apr 07 2015

The Georgia Nursing Leadership Coalition (GNLC) will hold its Leadership Institute, “Widening Your Leadership Lens: Preparing for the Board,” at Clayton State University in the Harry S. Downs Center on Monday, May 11.

The purpose of the Institute is to provide leadership training for nurses that will begin to build knowledge and competencies needed for effective board leadership. According to GNLC, nurse leadership at the Board of Directors’ level is critical for promoting the viability of healthcare organizations. The Institute’s objectives support the Robert Wood Johnson/AARP “Future of Nursing: Campaign for Action” initiatives to promote nurse leadership on hospital boards in moving forward the agenda of the Institute of Medicine’s 2010 report, “The Future of Nursing: Leading Change, Advancing Health.”

The Institute is co-chaired by Clayton State Associate Professor of Nursing Dr. Jennell Charles, and Janis Dubow, MSN, RN. Dr. Lisa Eichelberger, dean of the College of Health at Clayton State, is a member of the GNLC executive council and will also be one of the speakers at the Institute.

Individuals may register for the Leadership Institute by going to the Georgia Nursing Leadership Coalition’s website at www.georgianurseleadershipcoalition.org. Use the password    gnlcleadership2015

The Institute begins with a continental breakfast and registration, starting at 8 a.m. The program begins at 8:30 a.m., with keynote speaker Dr. Susan Hassmiller, senior adviser for nursing for the Robert Wood Johnson Foundation. The program will conclude at 4 p.m., and lunch is included. The Institute is being held in partnership with Leadership Women.

For logistical questions, please contact Vicky Stewart (678) 466-4964, executive assistant to the dean of the College of Health at Clayton State.

This website requires Internet Explorer 8 and higher.
Please update to the newest version.